[Issue #557] verifyText returns actual text of " " when there is text in the target


#1

New to Kantu here, so far I like this tool a lot. I’m puzzled though by what looks like it should be a simple check that is failing for reasons I cannot figure out.

I have a pretty simple script that is checking text in various locators and 90% of the time this works, but in some cases Kantu does not seem to find any text when text is clearly present.

Here you can see Kantu is finding the target that I’ve defined, text is present.

In Kantu when I run verifyText it shows the actual value at the target is " "

I’ve even tried changing the target to the entire page, just looking for the word “Your” and it does not find anything. But in other verifyText checks I’m doing everything passes.

Hopefully I’m just making a rookie mistake here. Any suggestion/alternate way of doing this is greatly appreciated.


#2

It is difficult to help without having access to the page.

But as an alternative, you can check for text in the source with sourceSearch.


#3

Thank you for the reply. I did discover the sourceSearch function when I ran into another issue shortly after this one so I will definitely give that a try. I thought it was interesting that the tool is identifying the location on the page but not able to read the text. It’s an older site and there are probably some odd tags or syntax at that location it is having a hard time parsing. Not a big deal. Really liking this tool.


#4

Table cells sometimes start with /n and storeText reads only one line. So that it seems it’s empty. I know it’s weird. I’d love that to be changed. To me it’s a bug. And I’d love for storeText to store every piece of target even if it’s enclosed in more children tags. But i’m not a developer.


#5

@commensal fully agree

Plus, while testing this I found there is an issue with storeText. It sometimes does not return the expected data. So I moved this thread into the bug section and we will fix it ASAP.

@stevent I am quite sure that this bug is also what causing your issue. So please try again after the next update.