[issue #46] XType doesn't seem to work on particular website

I’m trying to open “cheat console” on https://dtf.ru which is done by pressing “~” key.
I try XType | ` and XType | ~ and XType | ${KEY_`} and XType | ${KEY_~} and nothing works for me. Command is done successful according to log, but console is not opened.
Can somebody check this out and confirm?

What is supposed to happen on this website? I opened it, pressed “~” on my keyboard and nothing happened? Anything else I am supposed to do first?

If you press ~ console opens up:

Nothing other then pressing key needs to be done.

Ok, so on my keyboard it is ^ in Chrome and ´ in Firefox.

But when I test with xtype I get:[error] Failed to XType '${KEY_^}'

Since we released xtype I learn about keyboard shortcuts I did not even know they exist:wink:

The issue here is: xtype works fine on this website in general, but the´^ keys are not supported yet. I added them to our todo list.

1 Like

Can you please add other buttons? Like | \ / ? etc…

Note that you can send any kind of text already, e.g.

  • xtype | hello in Chinese is 你好
  • xtype | the first row on my keyboard is ^!"§$%&/()=?

but sending this text does not simulate the actual keyboard press. This is what the ${KEY_ENTER}, ${KEY_A},… special keys are for. And in the first versions of xtype not all possible keys are included. We will add them with future updates.

Example: / from your list is (on my keyboard) on the key 7, so a press of this key can already be simulated with ${KEY_SHIFT+KEY_7}

So presumably if I rebind my keylayout I might get the result?

I tried to remap Num0 key, since I’m on a laptop and this key is on the Doc page of XType.
But, when I try to use it:

[info] Executing: | XType | ${KEY_Num0} | |

[error] variable “KEY_NUM0” is not defined

I explore this more.

  1. I remapped ~ to F15. And it didn’t work.
  2. I remapped ~ to F1. And now weird things are going on. If I hit F1 manually on my keyboard then console does show up. But if I run Xtype with F1 then Chrome help page opens up instead of console on the page.

Ok. I don’t why but this site doesn’t recognise Xtype as keystrokes. Might be an interesting case for Kantu developers?

Hmm… as a test: Do an XClick on this page first, to make sure that the page (not the browser) has the focus. Does that help?

I read your mind. Exactly what I’ve tried. No luck :roll_eyes:

Any thoughts? @admin

Is this abandoned by everyone from Kantu?

Hi!, thanks for asking. It is not abandoned at all :wink:

The situation is as follows: I confirmed the issue and created a ticket for it (#46). So the feature “Extend keystroke support” is on to our todo list. Just note that it might take some weeks before the feature shows up in the released version, as our todo list is quite long currently. (If you have a Kantu Enterprise License with priority support please let me know, I can then push the ticket to the top of the queue).

Thanks for replying. BUT… This not about “Extended keystroke support”.

Please read my posts above. Even if I remap keys site does not understand it.

I remap F2 to `~
Now I open the site. XType F2 - NO EFFECT.
I press manually F2 - CONSOLE OPENS.
XType F2 again - There is an input in console window with ```````

So site does not recognize the way XType is typing. But when this is irrelevant it gets the input.
I don’t know how they do it. But this seems to be flaw in XType implementation or very smart workaround of the site builders.

Well, I can not tell you yet how they do it, but I have added this website to the ticket, too. So when we work on this xtype update, we will also research this website. In other words, I am pretty sure that after the next xtype update, this website will work as well.

1 Like