Internal variable "!URL" not supported

Hi there,
I just found this fantastic tool and installed today to do a demo of it, but I’m having troubles getting the URL.
This is what I’m seeing in the logs.

  • [info] Executing: | store | ${!URL} | id |
  • [error] Internal variable “!URL” not supported

I’m using the Firefox plugin.

Thanks in advance for your help!!!

This works ok for me:

{
  "Command": "open",
  "Target": "https://a9t9.com/",
  "Value": ""
},
{
  "Command": "echo",
  "Target": "url is ${!URL}",
  "Value": "green"
},
{
  "Command": "store",
  "Target": "${!URL}",
  "Value": "id"
},
{
  "Command": "echo",
  "Target": "id is ${id}",
  "Value": "blue"
},

Now is working, and I don’t understand why it wasn’t before.
But thanks!!!

I believe we need to open an url first( commend: open | Target: Any URL | Value: ID) or choose a tab first (commend: selectwindow | Target: tab=0 | value: ).

I get the same error

" [error] Internal variable “!URL” not supported"

{
“Command”: “store”,
“Target”: “${!URL}”,
“Value”: “myurl”
},

That same code works in FF though, but not in chrome, in FF it echo-ed fine – so it’s something with my chrome