Im unable to make a macro create a file

This come from this post.

I was thinking the problem was my python scripts were not working because the file is not created but after some testing it seems the problem is kantu can not create files.

First, i have a python script with 2 parameters, file and value:

“script.py data.csv 40”

And gives an output, then i made a script on RPA to process that output to a web, so if i have the command “script.py data.csv 40 > output.csv” i can read the output.csv in RPA and everything goes fine, since i did this manually all ok, but when xrunandwait command was added i want to do this automatically, so RPA call command “script.py data.csv 40 > output.csv” and then read output.csv and continue doing things, but the file is not created.

I tried a lot of things, because i believe the pipe “>” maybe causing trouble i modifuy the python script to create the output file directly in the code and work on CMD but not on RPA then i think maybe too much parameters, so i modify the python so the 1st argument file is not given and read direct from the code, so the only parameter is the value, so script.py 40 in CMD creates a output.csv file with the result, but not in RPA, then maybe python must be called from the python executable and then the script, but i have pytthon.exe in my PATH, then i compiled the script to an .exe with all the dependencies and test on a machine without python and still works, but not on RPA, then i tried doing a .bat calling the script, no luck either, i saw the video example xrunandwait again


and saw the powershell example with all the parameters, so i did a PS calling to my script, testing in PC ok but in RPA doesnt work. Im tired of triying and i have no f***ing clue of what is happening and why im unable to make a so simple thing.

EDIT: I did a very simple python script:

import re
import sys

file= open(“output.csv”,“w”)

for x in range(1,6):
#print(x)
file.write(str(x))
file.write("\n")

ficherosalida.close()

No parameters, nothing, keep it simple , it creates a file and then writes numbers from 1 to 5.

And this so simple thing doesnt work either, in CMD works perfect but when i call this script from inside RPA macro, it ends with error code 0 (success) but the output.csv file is not created.

Strange…so whatever you call with XRun does not work?

HAve you tried the DemoXRun macro that ships with UIVision? Does this work for you?

I solved the problem its look like when you call an external program the program is run not in its folder, but in some RPa limbo, so i guess the file is created in some unknow part of the computer or memory or another universe.

The key is using always absolute paths, relative paths doesnt work, you must user absolute paths in every, in rpa and in python

so i finally got my script working.
thank you