I have a probleme with xclick

hello using xclick I want to automatically click on a button from an image but the software cannot click on it although it works on my windows desktop. when I press find to be sure that my image is compliant it finds the position. how to solve the problem?


I use Xclic and it works great so Xclic works perfectly.
You have probably recorded an inaccurate image, save the image in a very precise way, possibly not containing parts of other images.
You can record selector image directly (the circle).
The problem is almost certainly due to the bad image you used to select the choice

xclick is good but for specialy for this windows its don’t run, i don’t know why, i can’t click, when i click on "find’ for test my command , the picture is recognise , i tried double click at other part of the picture but i have the same problem. i tried too use only keyboard TAB , UP and ENTER

Hi, this windows seems to part of an installer, or? If so, is this installer running with admin rights, while the browser/Ui.Vision is running as normal user? This would explain while the image is found, but the XClick or XType are not received.

Solution: Run installer as normal user, or run Ui.Vision as admin

1 Like

Hello Ulrich, with your help I was able to solve the problem! just before this window there was a button to install the software on all users (which launches with admin rights), so I chose the other button to install only for me, and it works

Thanks a lot !!!


unfortunately I have some software parameters that can only be installed via admin rights, is it possible to launch ui vision in full admin mode?

Nobody know about this problem ?