HTML with autorun worked yesterday, but not today

Yesterday I was able to export a macro: right click, Export as HTML (with autorun), and to run it using something like this.

Today I have modified the macro and want to export it again, but the export no longer works. I see no error message or dialog, but there is no .html file generated.

The main thing I think has changed since yesterday is that I started using “File system (on hard drive)” storage mode, but I don’t think that should change anything?

Also, I had difficulty yesterday finding where the .html file would be saved, but eventually found it by searching. Today I cannot find it (i.e., it seems not to be created). I even tried uninstalling Kantu and reinstalling, but it I still can’t export to HTML (with autorun).

I’m on a Mac, Chrome 72.0.3626.121, Kantu 4.0.2.

Any suggestions? Thanks.

The file should be saved in your current Chrome download folder - do you find it there? See also Where does Kantu save files?

On a different note, you can also use “yesterday’s HTML file” with your new macro if you use the macro=NewMacro name switch.

Thanks, I did read where the file was expected to be saved. However, I have never seen anything get saved in that location by Kantu (which is $HOME/Downloads). When I did find “yesterday’s” .html, it was in a directory a couple of levels above my working directory at that time, which was quite unexpected.

Thanks for the macro=newMacro workaround. I was able to make this work by importing the macro manually into Kantu, and then specifying its name (with no path or extension, as in macro=xyz where I had imported from xyz.json). Is it possible to specify the new macro via a path and filename (assuming of course that I “Allow access to file URLs” in the Kantu extension)? It didn’t work the couple of ways that I tried it, e.g., by specifying macro=file:///xyz and variations on that.

Thanks again.