How to set speed anytime (setSpeed)

I am using your UI.Vision Kantu for automatisation testing. I am missing Selenium comand setSpeed which is greate. At any time (inside macro, formely test case) it is able to set / change speed as I need it. Your software do not support it. Is it possible to add this to your UI.Vision Kantu?
I saw the variable: !REPLAYSPEED but as I suppose, it is possible to set speed only with three values and for whole macro. Adding setSpeed command would be greate, but if it is possible to set variable !REPLAYSPEED by number in miliseconds and use it at any place within macro, it could solve this situation.

Thank You

Hello Tom,

I believe this is what you are looking for:

 "Command": "store",
  "Target": "39",
  "Value": "!timeout_wait"

This will set the time that Kantu will wait until the element appears to 39 seconds.

Hope this helps.

Hello Adam, this don’t work for me.

There is definition:
!TIMEOUT_WAIT (read/write) - How long to wait for an element to appear before reporting an element not found error (implicit waiting)

It is not about how long to wait for element. It is about interval between executing commands.
In Selenium IDE there was command “SetSpeed” which was doing exactly what I need.

Now there is this solution:
“Command”: “store”,
“Target”: “Medium”,

But you can use only 3 options for speed:
Slow = delay 2s
Medium = delay 0.3s
Fast = no delay

With command “setSpeed” there was the value in miliseconds -> unlimited options for setting the speed (delay).

If there is a section in your macro that needs a longer time than as a workaround you could add a pause command in between your commands

1 Like

Hi @tom4s. The suggestion of @User9898 Adam is the best workaround. I always set !REPLAYSPEED = Fast when running my scripts but I notice that in some sections, I need to slow down (for the webpage to catch up). So I would add a PAUSE 400 (=400 milliseconds) in those instances.

I usually discover this when I loop through a repetitive process where it may work 9 out of 10 times but occassionally fail. So I add a delay (PAUSE) right before the command that fails.