Google chrome unresponsive


After a few successful commands(via cmd) I need to scroll down a page(which loads on scroll), by clicking a tag at the bottom of the page.
It usually worked fine but suddenly when I ran it several times after one another google chrome becomes unresponsive. (It happens after the 7th iteration)

  "CreationDate" : "2022.09.05",
  "Commands" : [ {
    "Target" : "xpath=/html/body/div[8]/footer/div[6]/div/span",
    "Description" : "SearchParams Scroll1",
    "Command" : "click",
    "Value" : ""
  } ],
  "Name" : "macroScripting"

I tried to delete the cache and cookies but it still happens.

Screenshot 2022-09-05 at 11.52.34

Any Ideas what I could do?


it now happens with other commands too…

Any chance that you can provide us with a test macro? Maybe something that shows the problem on a public website?

For future reference :slight_smile:

I could solve the problem regarding chrome freezing.
In my development environment I use eclipse to code my script. From there I start the application, which starts chrome and RPA via a java subprocess.

It appears that this subprocess is hanging and with it, chrome freezes as well. When I run my script via cmd, chrome does not freeze.

1 Like