Generated autorun HTML not working and launching from BAT file

Hello, very new to UI.Vision RPA and working to migrate a fairly large operation from iMacros. Using UI.Vision RPA 6.2.6 for Firefox.

I have my working macro and select “Create autorun HTML”. I have this downloaded HTML file named “freegaltest.html” and placed in the same folder as the JSON macro "C:\automation\UIVisionRPA\macros". Trying to open this HTML directly gives me the following error in FF: “Firefox can’t find the file at /C:/automation/UIVisionRPA/macros/”

Is there anything else necessary to launch my macro through FF for this? The filepath (C:\automation\UIVisionRPA\macros\freegaltest.json) should be valid.

Additionally, I was looking for the proper formatting to launch the html for the macro from a batch file. When testing I’m not even getting the same error as when launching the HTML directly, I’m only getting FF to open up, so I know I’m still missing something. I’ve tried a few things but it roughly looks like this

“C:\Program Files\Mozilla Firefox\firefox.exe”

Any help is appreciated, thanks.

Edit (additional info): if I attempt to open the HTML file from it’s default download location, it opens and runs fine. If I attempt to move that HTML file anywhere else, it stops working and gives the above error.

You must remove .html from macro name

Read here the usage of command

A longer command line, this time with Firefox:

“C:\Program Files\Mozilla Firefox\firefox.exe” “file:///D:/test/”

In this example we use the command line send some values to the macro and we close the RPA software and browser after the macro is done.

UiVision is a great iMacros alternative, plus it is open-source.

Out of curiousity: What is the reason to use Firefox instead of Chrome? Uivision for firefox version works well, but feature-wise it is behind the chrome version.