First-time user, getting "No ipc available for the playing commands tab"

I’m on Linux Mint 19.2 Cinnamon, using Firefox 69.0 (64-bit). Installed UI.Vision Kantu for Chrome (from the Firefox add-on store; I assume it’s correct) version 5.1.9. Later installed “XModules - Extension Modules for Kantu”.

Can’t get a simple macro to run beyond the first “open” step. An “open” will work, opening the specified web page, but then give “No ipc available for the playing commands tab”. Doesn’t matter what step is after the “open”, it could be an “echo” for example.

For example, this does open the page, but then never gets to next step (another echo) after the open step:

[status]    Playing macro VodafoneRouter
[info]    Executing:  | echo | started |  | 
[echo]    started
[info]    Executing:  | open | |  | 
[error]    No ipc available for the playing commands tab
[info]    Macro failed (Runtime 1.00s)

Same problem happened before and after I installed “XModules - Extension Modules for Kantu”.

Am I doing something wrong ?

Very strange. Two questions:

  • Does the google page from open | actually load?

  • Do the demo macros work?

Yes, the google page does load.

I think the demo macroes fail with IPC errors of various kinds, but I haven’t really looked at them and only ran one of them by accident a couple of times.

Another thing: the Kantu window always stays on top of the main browser window, partly obscuring it, no matter what I do. Is this normal behavior ?

[AHA ! Found that if I open Kantu and run a macro, any macro, it will fail with IPC error at open step. But then any macro I run after that DOES work. No more IPC errors. So it’s only on the first open command in the first macro I run after opening the Kantu window. If I close the Kantu window and open it again, then again, first open step in first macro I run will give IPC error, subsequent macro runs will run fine.]

Running into other problems. SInce Kantu window is stuck in front of browser window I’m manipulating, can’t get key-press of Enter to work. Kantu is able to type characters into fields on the page, but not submit the form by sending Enter.

Also, created a bookmark containing

javascript:(function() {try {var evt = new CustomEvent(‘kantuRunMacro’, {detail: {name: ‘VodafoneRouter’,from: ‘bookmark’,storageMode: ‘browser’,closeKantu: true}});window.dispatchEvent(evt);} catch (e) {alert('Kantu Bookmarklet error: ’ + e.toString());}})();

and it does nothing. I’ll have to play with it, not familiar with putting Javascript in a bookmark.