File uploads with variable filename from csv


#1

Hello - hope you can help with something.

I’m using a macro to fill in a form. I’ve loaded a csv with 3 columns. Columns 1 and 2 contain text and I’m using these and type command to fill the form with {!COL1} and {!COL2}

I then need to upload a file for each form and the filename is in column 3. I can get the file upload picker to open, but then can’t fill in the filename box with the contents of ${!COL3}

The log I get is:

[info]
Executing: | click | xpath=//*[@id=“data-print-book-publisher-cover-choice-accordion”]/div[2]/div/div[1]/a/h5 | |
[info]
Executing: | click | id=data-print-book-publisher-cover-file-upload-browse-button-announce | |
[info]
Executing: | type | | ${!COL3} |
[error]
Internal variable “!COL3” not supported

Being new to this, I also tried {!COL3} in Target instead of Value. That gave me the error message: {!COL3}

I’ve checked the csv and it has 3 columns, as it should. I’ve also tried changing {!COL3} to {!COL2} for this and it doesn’t type that either.

Any suggestions?

Thanks
Ben


#2

For file upload issues see Chrome update disabled the file upload feature? {"code":-32000,"message":"Not allowed"}


#3

Hi Ulrich - thanks for your reply.

Ben