File upload automation: Issue about Warning #300

Hey there
After the last update, I cant run my macros due to this issue. It says Warning #300: Web page connection issue. Retrying last command.
It stuck on this command

{
“Command”: “type”,
“Target”: “//*[@type=“file”]”,
“Value”: “/myfilepath/clean.csv”,
“Description”: “”
},
I have tried some solutions on the forum but did not help. What would be the issue? I have tried removing and re installing the chrome extension. I updated the latest chrome.
Thank you so much

Hi, do you have a test macro (that we can run here) us that shows this error? If that is not possible, a screen video would be helpful. If you do not want to post this information in the forum, you can also email it to team AT a9t9.com on and just mention this forum post.

Does it happen during a file upload (I am just guessing because of your code snippet).

This file upload test macro works for me:

{
  "Name": "file_upload",
  "CreationDate": "2021-12-17",
  "Commands": [
    {
      "Command": "open",
      "Target": "https://ocr.space/",
      "Value": "",
      "Description": ""
    },
    {
      "Command": "type",
      "Target": "id=imageFile",
      "Value": "C://test//ocrtest1-50.jpg",
      "Description": ""
    },
    {
      "Command": "click",
      "Target": "linkText=Start OCR!",
      "Value": "",
      "Description": ""
    }
  ]
}

Hello,
Thank you for the response. Here I will send you the video. I have tried your test macro and it also did not work for me.
screen-capture

Thanks for the screen video. => I found out what the issue is. For file uploads to work, you need to enable “Allow access to file URLs” for the RPA extension.

See here:

Without this switch set to ON, you get the #300 timeout warning, and then after a while the ipc error:

  • [warning] Line 2: Warning #300: Web page connection issue. Retrying last command.

  • [error] Line 2: ipcPromise: onAsk timeout 10000 for cmd “RUN_COMMAND”, args “[object Object]”

Oh now it works! thank you. It was working actually before. And, this URL access option was allowed before. After the update somehow this option was turned off. Thanks again.

1 Like