Failed to Create Folder:unidentified

Can’t even get out of the gate with UI.Vision —
UI.VIsion RPA 6.2.6 in Firefox, went to create a folder:
“Failed to create folder: unidentified”

Do I just cut my losses (as I have spent three hours just getting Firefox to show the UI.Vision Add-on)…and use something else?

Bit frustrated -

You can create the folder yourself manually and then indicate the path in the ui vision settings

Is that issue on Mac, Windows or Linux?

And do you see the same issue with Chrome?

To me it sounds like the default root folder (see XModule tab) does not exist or has no write permissions.

This is where I ask you how I would go about creating the folder manually.
Do you understand the frustration yet?

Sorry, thought I mentioned I am on Windows, but the only reason I am here (and not on UI Path) is that I need a solution created for a MAC – testing on Windows (and trusting the macro transfer is as simple as the youtbube vid suggests, but not holding my breathe for fear of passing out).
I will try Chrome, but that is not a solution is it -if the app is said to work on Firefox, then I would like to know the solution to keep it on Firefox.

XModule tab in Settings - is this what you mean? I “tested” it and it appeared successful.
I have no idea what you mean: “default root folder does not exist or has no write permission”, but if what you mean is that the “Home Folder” in “FileAccess XModule/Setting” should have a file directory identified? it does, as follows: C:\Users\redacted\OneDrive\Desktop\uivision. And, in checking the uivision drive (at left) all Permissions are set to “Allow”. Uncheck “Read-Only”. Restarted App. Tried creating folder: same error.

As well: in the “documentation”, the direct to hard drive symbol is does not appear in the app to show the XFiles storage mode is active – if that means anything?

It is that simple :slight_smile:

Yes, the “home folder” is probably the problem - but I am not sure why.

Can you try with a different folder e. g. c:\test\ ? Maybe OneDrive is causing the issue?

Thank you for your response admin,
I dropped Firefox and switched to chrome, which immediately populated the Add-on, and appears to work at this point.
I dont have time to troubleshoot Firefox’s or UI.Vision tech issues for them – I work for a living. JK – I would really prefer Firefox as I try to keep my Google footprint limited - but oh well.

Thanks again,

1 Like

Thanks for the feedback!

The UI Vision Firefox version will get a major update as soon as Firefox officially supports the new manifest3 format for extensions (probably end of this year or early next year).