Error when trying to pass AWS S3 Signed URL

I get an error when try to pass AWS S3 Signed URL (like I use correct filetype: png and the same file without signed URL works just fine. Signed PDF files also don’t work with similar error. It is strange, because signed and unsigned files are identical.

  ParsedResults: [ { 
    FileParseExitCode: -10,
    ParsedText: '',
   ErrorMessage: 'Parsing Error: Please check the image. The image is corrupt.',
   ErrorDetails: 'Please check the image. The image is corrupt.' 
  } ],
  OCRExitCode: 3,
  IsErroredOnProcessing: true,
  ErrorMessage: [ 'All images/pages errored in parsing' ],
  ProcessingTimeInMilliseconds: '429',
  SearchablePDFURL: 'Searchable PDF not generated as it was not requested.' 

My first guess is that the encryption confuses the automatic file type detection. Have you tried adding filetype=png to the API call?

I could not test because I don’t have your access key. So I only get <Message>Request has expired</Message>

If adding the filetype does not solve it, please provide a valid AWS S3 URL for us to test it. If you do not want to post it in the forum, please send it directly to us.

I tried filetype, but without success

here is link, I made it valid for 48 hours

Thanks. I confirmed the issue and we will debugging it ASAP. If possible, please keep the link valid for more than 48h, I am not sure if we are that fast :wink:

Here is a new link that expires in a week

Thanks for the links. We debugged this and found out what is wrong. The current code fails to download images and PDFs from signed URLs. So the image never reaches our OCR servers. As for the solution:

  • Do you have a PRO or PRO PDF plan? Then please contact us and we can add a solution to a PRO/PRO PDF endpoint on short notice. (In your mail, just mention this forum post).

  • Do you use the free ocr plan? Then please be a bit patient. The issue is now on the todo list for one of the next updates, but I don’t know when exactly the signed URL support will be available.