[error] Invalid tab ID : 5

Hi,

I must be the unlucky guy since I have another problem running my macros in command line. May be it is related to my previous topic : [UI.Vision RPA] No tab for dashboard yet

For test purpose, I have the same macro code running from the command line 5 times. This macro open a website to catch the ip address. So I run a serie of 5, one same macro after another (as it is said in the video https://youtu.be/P-yo8aroD-g) waiting for the log file and then launch the next one.

I start macro 1-4 with closeBrowser=0&closeRPA=1, and the last macro (5) with closeBrowser=1&closeRPA=1.

So after several series everything was fine. But for the last one, the macro 3 stopped (even if !errorignore is set to true) to this [error] Invalid tab ID:5.

I use a Firefox browser. My macro just opens a website (“http://whatismyippro.com/”), and doesn’t close any tab or doesn’t use any tab command.

I solved this problem with my previous solution (testing a ok.csv I create at the beginning of the macro to test if the macro starts and if not kill Firefox for a fresh start of the command line).

What I can see when I start my serie is that Firefox (the home page of Firefox is about:blank), displays a web page (ui.vision.html) saying it starts RPA. The RPA starts. Then the macro runs and open the website (“http://whatismyippro.com/”) in the same tab. Macro 1 ends.

Then Firefox displays again the web page saying it starts RPA (in the same tab where the http://whatismyippro.com/ was). The RPA opens. Then in the same tab the http://whatismyippro.com/ page is “restored”. The macro starts again and opens again the http://whatismyippro.com/ page, etc.

But in this case the Macro (the 3rd one to be started) stopped immediatly on this error “[error] Invalid tab ID : 5”. I suppose the “ID : 5” has something to do with the fact that previously it opened 4 differents pages : 1) start RPA page 2) my ip page 3) start RPA page 4) my ip page.

So may be I did something wrong. May be I have to open a new tab in my macro after the start and run the macro in this new tab. May be I should define my Firefox homepage with a real website (google). Since it doesn’t happen all the time I think it is the same kind of problem than my previous topic : [UI.Vision RPA] No tab for dashboard yet. A problem when opening the IDE (tempo ?).

Thanks for reading (!!) and your possible help.

Eric.

Thanks again for the info. This issue sounds similar to [Recreator Required] No tab with id: 1662 - which is already on our todo list. I will update this post once we know more.

This is a good workaround!