Error file not found and files does exist

Hi everyone
I’m starting to use this software, and yesterday I could read and write from/to a csv file without any trouble. Today I decided to start working seriously and changed the path of my local macros. After this, I also changed the location of my macros, images and other files that Kantu uses. But when I tried to run my macro, it can’t find the csv file. The lines is
{
“Command”: “csvReadArray”,
“Target”: “C:\Users\Bot\Documents\BotFacturasManuales\Output.csv”,
“Value”: “Output”
}

I do know that the file exists and checked several times the path, it is correct. And yesterday it was working just fine, I just changed the path of my kantu macros.
What I had to do with other files was to move them inside my Kantu folder, but do I really need to do that with every other file I want to work with?
My kantu folder is in “C:\Kantu”

Thank you

Are you sure that RPA ui vision can read csv out of its default folder ?

I have never used the full path as a function but I only indicate the name of the csv and all my csv are saved in the datasources folder of ui vision.

I think xmodules can not read outside the default folder (datasources), you can change it but you must add one unique path.

1 Like

oh, so it is that, I do need to have my csv inside? :c
Well, I have to modify all my other codes to save in this one
Thank you

Example i set in ui vision RPA option the folder in my pc with all data of ui vision

After i add name of csv only in macro code

{
  "Command": "csvRead",
  "Target": "test.csv",
  "Value": ""
},

test.csv have in a custom path in my pc, is ui vision folder with all ui vision data.

In the latest version of ui vision allow full path but i think is inside the folder with all data not a generic path in my pc (i never tried full path function).

I knew this was possible, but I didn’t know it was “necessary”. I thought I could just call the full path.
Thank you.