Error during on command TYPE during "long" macros

Hello everyone,

I am working on a macro which uses a dynamic form on firefox, it adds a new line of the form at each iteration.
So I am using a Type inside a While and after about 44 iterations (about 4-5 min of execution I get this error :


Line 10 (Sub: FillProductsPhytos): Web page connection issue. Retrying last command.

At Line 44 in Phytos

Line 10 (Sub: FillProductsPhytos): lost background heart beat when running command

At Line 44 in Phytos

I tried to use a Click with the same xpath right before the type which works perfectly but the type does not.
I also tried to use a SelectWindow right before the type but the error remains.
I also tried on chrome in which the macro stops on random commands without stopping or displaying an error message.
I have also installed XModules.

Would you know a way to work around or fix this ? A way to avoid using Type Maybe ?

Thank you.

Do you have a test macro that shows the issue?

One workaround is to use XType instead of Type.

After further testing it turns out the issue was due to the use of type | id=myId, the id search was taking too long causing it to timeout so I replaced it by the full path of the input from the html root and it works.

Thanks for your answer, if you know how to improve the efficiency of the search by id, I could use it