Error Cannot read property 'substring' of undefined

I dont know if this is a bug or is my mistake but the same error message i see appears also out of Kantu and is not normal.Here is the log.
“Executing: | executeScript_Sandbox | {myVar1}.substring(0,10) | MyNewVar | [info] Executing: | echo | {MyNewVar} | |
[echo]
undefined” <<<<--------- Undefined Variable ? But already i saved the variable {myVar1} with StoreText and on Echo of {myVar1} appears correct the data.
Also if i use “str.substring” instead of “substring” then appears the message “Cannot read property ‘substring’ of undefined”.
Is it anything wrong on my side ? Or is a bug? Please let me know solution if is my mistake.Thanks !

1 Like

Also the same with StoreEval * [info]

Executing: | storeEval | storedVars[‘MyVar’].str.substring(0,10) | MyNewVar |

  • [error]

Error in runEval code: Cannot read property ‘substring’ of undefined

Is not a bug finally.I needed to read documentation and set new name to Var.Problem is solved you can delete the post.Thank you !