Error 101, Warning 300 and Macros Failing without Error

This is an issue that has been plaguing my team for a while now, and we cannot find any sort of solution.

Frequently, our Macros fail without any fault of the Macro itself. These Macros have had many successes, so there is nothing wrong with the Macros themselves. UI Vision will fail, at random, and it’s become disruptive to our workflow.

The Reasons for Failing are Thus:

  1. Error 101 Could not establish connection. Receiving end does not exist
  2. Warning #300: Web page connection issue. Retrying last command.
  3. Error #180: No connection to browser tab
  4. No Given Error in Logs, Macro just fails
  5. Image ‘imageName_dpi_120.png’ (conf. = 0.6) not found (This happens randomly, but the image is found when re-running the macro or executing the command alone)

Macros fail at any given step, at random, but when executing that step alone it passes. These commands can be anything, whether they’re Selenium IDE Commands or XModules doesn’t matter. Running the Macro again will pass at the previously failed step, but fail at a different step at random. Sometimes we can get through an entire Macro, only for another Macro to fail at random. We cannot run Test Suites because of this issue.

I’ve dug through these forums searching for answers. All threads end with saying these issues are fixed (they are not) or are left with no definitive solution. I have tried backdating to v6.2.8, I have tried CLI, I have tried running in Incognito, yet these issues persist. It’s frustrating because we have invested a significant amount of time into creating these Macros only for them to not work for reasons that are seemingly no fault of our own. We have all also purchases Pro Licenses.

I cannot share any screencasts of the SUT due to it being private info, but I’m not sure if screencasts would be of any help anyways since this failing behavior is completely random.

Has anybody found a fix for these issues?

We are currently busy with the manifest V3 transition (hopefully done soon), and then we will address these issues. They continue to be on our todo list. Some triggers for these issues have been fixed in the past, but unfortunately not all. We are aware of this!

For now, the recommended solution for running RPA 24/7 is to use the command line and re-run the macro if such an error happens.