Encountered "Invalid tab ID: 20" error when I run from PowerShell command line

I am working on the Ui.Vision RPA 6.2.6 and trying to run macro from PowerShell command line. Once run, the firefox browser was open correctly but then the error “Invalid tab ID: 20” is shown in the Logs section of Ui.Vision. Did anyone know how i can fix it? Anyw workaround? Thanks.

Hi, can you test if this solution works:

Thanks for your advice. I have tried your suggestion but failed. I still got the similar error “Invalid tab ID: 2” in the log screen. One thing i have added is the loadmacrotree=1 as when the macro runs, the macro list was not shown in vers 6.2.6 and thus I need to add this parameter to shown. Then, I have also set the pause = 25 s in the CLI script but no help. Any hints? Thanks.

Can you provide a screen video of the issue?

Also, does it always happen?

loadmacrotree=1

I would not use that. It just makes the RPA software start slower. We have this command mostly for backward compatibility.


i have tried to captured a test i have written for your reference. Please see if there’s any hints. Thanks.

I get “This video cannot be rendered because your browser does not support the codec.” in Firefox and Chrome.

Can you try with MP4 format? Or upload it to you Youtube or similar?