Discord (Chrome) - sendKeys not working properly

Hi, I’ve been trying to run an automated bot that sends messages but it doesn’t appear to work. The sendKeys (Enter) option does not work properly. This means I cannot send messages, as on Discord, there is no send button on the app, enter is the only way to type messages.

Here is an example code that does not work properly, upon reaching the “sendKeys” enter option it actually refreshes the page, which is very confusing.

{
“CreationDate”: “2018-10-20”,
“Commands”: [
{
“Command”: “open”,
“Target”: “https://discordapp.com/channels/445911926682419200/445911926682419204”,
“Value”: “”
},
{
“Command”: “click”,
“Target”: “//[@id=“app-mount”]/div[1]/div/div[1]/div/div/div[2]/div[2]/div[2]/div[2]/div[1]/form/div/div/textarea",
“Value”: “”
},
{
“Command”: “type”,
“Target”: "//
[@id=“app-mount”]/div[1]/div/div[1]/div/div/div[2]/div[2]/div[2]/div[2]/div[1]/form/div/div/textarea”,
“Value”: “hi”
},
{
“Command”: “sendKeys”,
“Target”: “//*[@id=“app-mount”]/div[4]/div[2]/div/div/div[2]/div/button/div/span”,
“Value”: “${KEY_ENTER}”
}
]
}

If anyone can help find alternatives to send messages or have a fix please let me know, thank you!

Stay tuned for the release of the new XType command in the very near future, it will solve this issue.

Meanwhile, Kantu works with the discord app.

When do you think the XType command might be available?

XType is available meanwhile. So when you use xclick and xtype instead of the standard selenium ide click and sendkey commands, the discord app can be automated easily.

Short screencast of kantu and discord chat:

Legoego, did you get any solution for the same? I’m facing the issue & not able to figure out next step.

I am not Legoego, but did you try using XClick? It works for me.

Try XClick or XType.