Desktop not working on macOS Monterey

Hello,
I have installed the uivision-xmodules on my macbook pro running on Monterey.

I changed the Privacy Settings to allow the XModules
Accessibility: kantu-xy-host, Google Chrome
Files and Folders: This is blank ( it doesnt have kantu-xy-host or kantu-cv-host)
Screen Recording: sh, kantu-cv-host ( doesnt have kantu-xy-host)

When I try to run any Macro to open safari using xtype and xclick, it times out without doing anything.

I am trying to automate a script on safari.

Any thought or help?

Thank you

1 Like

Same problem. Privacy settings to allow the xmodules are not in files and folders.

Hello, all works fine on MacOS Monterey in our tests. => Do the XModules show as installed?

It sounds like all is installed ok:
Accessibility: kantu-xy-host, Google Chrome
Files and Folders: This is blank ( it doesnt have kantu-xy-host or kantu-cv-host) <= this is correct!
Screen Recording: sh, kantu-cv-host ( doesnt have kantu-xy-host)

Here are the security & privacy settings screenshots from a test mac with the latest Monterey:

I have the exact Monterey setup described by the Admin and the FileAccess XModule appears uninstalled every time I go back to it.

1 Like

Admin, thank you for your confirmation there is no file access kantu option. Echoing letsjoeblue here. I go into xmodules settings and i have to retest it for it to find it again as well.

dear admin,

The uninstalled fileaccess xmodule still says uninstalled even with these permissions. Thank you

Does it say this even if you click the “Test” button for it?