(Closed as outdated) [Recreator Required] visualAssert: No input image found for file name

What are the conditions where visualAssert will return the error: “No input image found for file name…”

I ask because I can see the image in my “Visual” tab.

I am attempting to run the “DemoComputerVision” macro. It initially failed on the image democv_startocr.png so I attempted to replace it with a new image named “democv_startocr_dpi_96.png” I could see the original and the current images but no dice.

I am currently attempting to text Kantu to see if it will meet my needs.

We have some reports that computer vision input images can not be found during macro replay directly after a fresh Kantu installation on Windows. Your post sounds like it is this issue, too.

Solution: This only happens directly after an installation. Closing Kantu and all Chrome instances once solves the issue. Then the issue disappears and never(*) returns.

*It might return after an extension update. Then closing all Chrome instances, and restarting Chrome/Kantu solves it again.

(Of course, debugging and fixing the root cause of this issue is on our todo list, ticket #435)

I’m also seeing the same issue with the VisualAssert and VisualVerify commands not finding the image even after it’s just selected and saved it.
Please clarify if there’s another workaround, as closing all Chrome browsers and restarting doesn’t seem to fix? Many thanks
(apologies for high-jacking the thread)

@Cootin Is this a fresh install or upgrade?

Hi, It was an upgrade.The demo examples also fail for the same reason.
(as a side note VisualSearch seems to run ok, but doesn’t fail when I expect it too ? )

So even after closing all browser instances the issue still remains? Do you see the same issue with Firefox, too?

VisualSearch does not fail even if no image is found, it just returns “0” as search result.

Has this been resolved?

Everytime i run now i get the following error

[error] visualAssert: No input image found for file name ‘UvXGpz_dpi_96.png’

I have tried shutting down browsers and Kantu, and rebooting. It isn’t a fresh install. If i record the image capture again and run the same error is displayed for the new file.

I just can’t figure out a workaround.

I’m running in Firefox

This issue - according to our tests - happens “only” after a fresh install or update, and goes away after a complete browser restart. Did you test with Chrome, too?

I haven’t tried it with Chrome. I purposely downloaded Firefox to use Selenium IDE and came across Kantu.
I haven’t found the Kantu extension for Chrome but I’ll will try it on that and report back. To be honest Chromw is my primary browser so that would make love simplier.

I have downloaded the chrome extension and the visual search works as expected in Chrome, so looks like a Firefox issue. I can also rename the visual captures which when using Firefox i couldn’t do.

Very happy.

I have the same issue on Chrome. It is a new install and the browser was restarted. The images exist under the Visual tab. Demo macros - DemoCanvas, DemoComputerVision - also fail with the same error e.g. visualAssert: No input image found for file name ‘canvas_wyoming_dpi_96.png’.

I am having a issue similar to these all too frequent for visual commands to be useful for me.
I often times have to restart Chrome every 30 min or so when writing tests or running tests with visual assert. When a visual assert command has been executed, it stays in execution mode. Doesn’t fail or pass. Is there going to be a fix for this in the April release?
Thank you!!

@dieblue Can you make a new post for your issue? I don’t think your problem is related to the issue described in this thread.

If we have a macro to recreate the problem, we can fix it with the April release.

1 Like

Old thread. I will close it and lock it.