Click on video play not working

Hi, I’m trying to do something fairly simple, open a page that has a streaming video (the weather channel), click on the play button for the video, and then click on the full screen button. I tried Click, XClick, XMove and #up, I recorded the macro by actually clicking on the button, but when playing back the Macro, the video does not start playing. Are there any limitations in simulating a click on a video to start playback?

This is the web page I’m trying to make it work with:

We are trying to put this on office TVs connected to a PC, but the page keeps crashing every few hours, and I’m trying to find a way to automate going to this page, starting a video and putting it into full screen every few hours so we don’t have to manually keep doing it.

I recorded the macro by actually clicking on the button

Did you really try XClick? I ask because XClick can not be recorded, only Click.

I suggest you use XClick (image of button). This should work. See also UI Automation

Thanks, yes, I changed the recorded click to XClick and the screen turns green for a moment, but the video does not start playing. I tried to add all the steps manually and record. Could it be because the player is not HTML? I think this is JWPlayer, and might be an older version on this site. I also tried using waitUntilObjectVisitible (or some similar command). Odd. Seems like it should work.

I also found out that I could do executeScript and make the player play with JavaScript, but the player does not allow the fullscreen option to be triggered with JavaScript, and the XClick is still not working. I even tried to also execute focus() on the player and then try to use XType to send the “F” character which should trigger the player to go full screen, but that also doesn’t work. It does if I manually do it myself after clicking on a player, very strange


I automate it for you, need only Xclick, working like a charm

This is the code macro

“Name”: “Play_Video”,
“CreationDate”: “2019-9-20”,
“Commands”: [
“Command”: “bringBrowserToForeground”,
“Target”: “”,
“Value”: “”
“Command”: “XDesktopAutomation”,
“Target”: “TRUE”,
“Value”: “”
“Command”: “XClick”,
“Target”: “play_dpi_96.png”,
“Value”: “”

You need to save play button with desktop automation.

Working well, click play :slight_smile:

1 Like

Thank you for your help, that’s working for you in Google Chrome? I tried, but the video does not start playing. I can get it to start playing by running the ExecuteScript for that, but then I still can’t get it to go full-screen :frowning:

Also, I had to add XMove, cause when I only have xClick it doesn’t seem to want to scroll down the page to the video player?

I use Kantu for windows 7 with browser firefox ESR 60 (quantum).

You must save the icon of play video in my macro the name is play_dpi_96.png

Working perfectly.

I have not a software to do a screencast, but i can guarantee that macro click play and the video start.

Have you installed xmodules of kantu ?

Xclick require xmodules installed

With kantu xmodules you can do all because it simulate the keyboard and mouse, every work it’s possible with Kantu xmodules and Desktop automation because it simulate the keyboard and mouse (it’s the same using keyboard or mouse).

The request of the post is “Click on video play not working” and I write a macro to play video, with other commands it’s possibile to scroll, activate full screen and others customizable, but the request is play video and the macro code do it perfectly.

I have a similar problem. Can you expand on how I save the button image?

You must use these commands

how do you get the above target of your play button - “play_dpi_96.png”

This is desktop automation, you must save the image of button (with ui vision) and after you can use it to detect the play button

Hi, I know this is an old discussion, but I’ve seen this issue several times asked by different users and I have a possible solution, so I thought it could be fine to join and share it. I signed up just to do this, so I’m really sorry if this bothers anyone.

I was having this issue of the “Play Macro doesn’t work” for a whole day, and I tried with a lot of things, especially uninstalling it and trying on several browsers A LOT of times, until I realized I was unable to save the macro I was trying to play. So I wondered if the commands I was introducing were actually being processed. I checked some things and realized the reason was that I was not creating a new macro (by clicking on the “+ Macro” button from the top left corner) I was introducing command lines in some kind of “temporal macro view” you can see the first time you open the “application tab”, which I guess isn’t ready to be used, because it’s expected that you would click on that +Macro button before starting anything.

tl;dr: before starting introducing commands click on the “+ Button”, then you could save it and play it (if your case is the same than it was for me)

I insist: I’m sorry if refloating this topic bothers anyone, I’m trying to contribute with a solution that worked for me.


PS: English is not my native language, my apologies if it isn’t explained properly.