Click on element takes to long, delaying script by 1 second each time (more recommendation)

Since version 7 when Kantu clicks on an element in the website, it pauses for around one second marking the element green for a moment (the green marking is extremely helpful !!! :slight_smile: ).

However that 1 Second delay is a problem if you have many clicks in your script, like clicking through a table with 300 entries. That adds 300 seconds to your total script execution. I know in the older script version 6 this took way less time.

Can you shorten the click time on a web site element as it used to be in kantu version 6?
Thank you.

image

Change command interval to Fast from settings.

It’s already set to “fast”. That is not do anything. The click would pause the script for the while it highlights the web element greet, and that takes a second or so. Too long if you do that 300 times in your script. (Note how much faster it runs when you remove the click line from the script)

{
“Name”: “ClickDelay”,
“CreationDate”: “2022-10-4”,
“Commands”: [
{
“Command”: “open”,
“Target”: “RPA Software Pricing”,
“Value”: “”,
“Description”: “”
},
{
“Command”: “times”,
“Target”: “300”,
“Value”: “”,
“Description”: “”
},
{
“Command”: “click”,
“Target”: “xpath=//*[@id=“content download-content”]/div[2]/div[2]/table/tbody/tr/td”,
“Value”: “”,
“Description”: “”
},
{
“Command”: “end”,
“Target”: “”,
“Value”: “”,
“Description”: “”
}
]
}

store | nodisplay | !REPLAYSPEED

This will speed up

Good thought, but just tested, does not make any difference. :frowning:

Just ran it on Firefox which still uses version 6 and runs super fast:

1 Like