Click no executed after update to 5.9.3 (Firefox)

My script stopped properly working after update to UI.Vision V5.9.3 running on Firefox.

Expected behavior:
click on input boxes identified by xpath

actual behavior:
no click is performed, no error produced. Just move on to the next step.

What was done to narrow it down:

  1. A new macro was recorded to do just that: click on one element.
    Replay the macro.
    Result: element not clicked.

  2. the find function identifies the element correctly

  3. xclick installed and replaced in the recorded macro, same behavior (but mouse moves near the location)

  4. slow down the script execution to see step by step and allow page to settle in. Result: no change, all steps are executed in Vision.ui (just not effective on the webpage)

The recorder script is:

{ "Name": "test", "CreationDate": "2020-11-15", "Commands": [ { "Command": "open", "Target": "https://www.w3schools.com/html/html_forms.asp", "Value": "" }, { "Command": "type", "Target": "id=vehicle2", "Value": "Car", "Targets": [ "id=vehicle2", "name=vehicle2", "xpath=//*[@id=\"vehicle2\"]", "xpath=//input[@id='vehicle2']", "xpath=//input[5]", "css=#vehicle2" ] }, { "Command": "click", "Target": "id=vehicle2", "Value": "", "Targets": [ "id=vehicle2", "name=vehicle2", "xpath=//*[@id=\"vehicle2\"]", "xpath=//input[@id='vehicle2']", "xpath=//input[5]", "css=#vehicle2" ] } ] }

site note: actual script and xpath is much more complex. However since above replicates my issue it’s probably easier to resolve the issue in above and then replicate to the various steps in my other script. :slight_smile:

Same thing here.

UI.Vision 5.9.3
Google Chrome Version 86.0.4240.198
macOS Big Sur 11.0.1 (20B29)

2 Likes

+1 here in some macros as well and I’m on Chrome so this isn’t isolated to Firefox. The element is found but not clicked. Something happened with the JavaScript handling of clicks.

I added an XClick right after the click as a workaround. Click focuses, XClick clicks.

2 Likes

Mine are being clicked twice instead of once.

edit: I’m using Chrome

@kron78 here is the thread for the double click: Click command on a button opens two tabs

1 Like

I had the same problem with ui vision and firefox, the macros did not click the elements and yet until a few days before they worked great,

I reinstalled the old version of ui vision and immediately after I reinstalled the latest version,

I restarted the browser and it seems that everything works well now again.

+1, Chrome, after updating to UI.Vision 5.9.3 visually clicks a JavaScript element but no response. Rolled back to 5.8.8. version 5.8.8 works well

Thanks for the test macro! => We confirmed the “clicked twice” issue. The “no click” issue is the same, technically 2 click events are sent in V5.9.3, and that is causing the appearance of no click. Of course we will fix this ASAP.

Meanwhile, just as FYI: The rollback is certainly a good workaround. Another workaround can be to use the Selenium IDE CHECK command to check the boxes (instead of using CLICK or TYPE for this purpose). The CHECK command is not affected by this bug.

{
  "Name": "clicktest",
  "CreationDate": "2020-11-15",
  "Commands": [
    {
      "Command": "open",
      "Target": "https://www.w3schools.com/html/html_forms.asp",
      "Value": ""
    },
    {
      "Command": "comment",
      "Target": "type // id=vehicle2",
      "Value": "Car"
    },
    {
      "Command": "comment",
      "Target": "click // id=vehicle2",
      "Value": ""
    },
    {
      "Command": "check",
      "Target": "id=vehicle2",
      "Value": ""
    }
  ]
}
2 Likes

Thank you for confirming. It would be a GREAT help if the fix was released right away instead of the normal release cycle. Firefox is easy to rollback, but Chrome isn’t. Otherwise all macros would have to be worked around and then modified again later.

Thanks for the follow up. I can confirm the check instead of click fixes the issue.
I updated my scripts and its working smooth again.

I confirm this bug too.

The bug must be solved because in some menu type the double click open and close the menu and in these cases can not use CHECK command

ClickAt is not affected of this bug :slight_smile:

We released V5.9.5 just now. The only change from 5.9.3 is the fix for this issue.

The Firefox version is available already, and the Chrome/Edge version should be available in the store in a few days.

Of course, if you see any remaining issues, please let us know.

2 Likes

I just got the update on Chrome, looks like the Chrome team isn’t delaying as much as before.
Thank you for the quick fix!