Click java button there isn't anything

I click the java button, there isn’t anything. I can’t save the value which in the attached clip.

There isn’t fail in the code. Here is the logs

2022-09-09T09:35:58.382Z - [status] Playing macro CafeF-newBV-Fill-General-DN-ChuaDieuChinh
2022-09-09T09:35:58.404Z - [info] Executing: | comment | if_v2 // ${!LOOP}==2 | |
2022-09-09T09:35:58.714Z - [info] Executing: | csvRead | BV-list.csv | |
2022-09-09T09:35:59.043Z - [info] Executing: | comment | end // | |
2022-09-09T09:35:59.353Z - [info] Executing: | open |${!COL1} | |
2022-09-09T09:36:02.247Z - [info] Executing: | pause | 3000 | |
2022-09-09T09:36:05.575Z - [info] Executing: | type | ID=ctl00_Main_txtNam | 2022 |
2022-09-09T09:36:05.930Z - [info] Executing: | select | ID=ctl00_Main_ddlQuarter | label=Quý III |
2022-09-09T09:36:06.281Z - [info] Executing: | click | xpath=/html/body/center/form/div[3]/table[2]/tbody/tr[3]/td/table/tbody/tr/td/table/tbody/tr[33]/td[1]/b/b/a | |
2022-09-09T09:36:07.135Z - [info] Executing: | pause | 3000 | |
2022-09-09T09:36:10.460Z - [info] Executing: | select | ID=ctl00_Main_lstData_ctl11_FinanceDataRowInsert1_ddlChiTieu | label=Vốn chủ sở hữu tính BV |
2022-09-09T09:36:10.820Z - [info] Executing: | type | id=ctl00_Main_lstData_ctl11_FinanceDataRowInsert1_txtValue | ${!COL10} |
2022-09-09T09:36:11.173Z - [info] Executing: | type | id=ctl00_Main_lstData_ctl11_FinanceDataRowInsert1_txtDisplayTitle | Vốn chủ sở hữu tính BV |
2022-09-09T09:36:11.518Z - [info] Executing: | type | id=ctl00_Main_lstData_ctl11_FinanceDataRowInsert1_txtSortOrder | 17 |
2022-09-09T09:36:11.864Z - [info] Executing: | click | xpath=//*[@id=“ctl00_Main_lstData_ctl11_FinanceDataRowInsert1_lbtnOK”] | |
2022-09-09T09:36:12.723Z - [info] Executing: | pause | 2000 | |
2022-09-09T09:36:15.040Z - [info] Executing: | comment | localStorageExport // D:\D-Download\CafeF\log | #DeleteAfterExport |
2022-09-09T09:36:15.360Z - [info] Macro completed (Runtime 16.96s)

You probably have to use Xclick to make sure the button is clicked

The line @id=“ctl00_Main_lstData_ctl11_FinanceDataRowInsert1_lbtnOK" executed
The xpath found
But there isn’t the successful notification in the web

Can anyone help me please

Did you tried XCLICK?

How to use it in this situation

I tried it

“Command”: “XClick”,
“Target”: “OCR=Thêm”,
“Value”: “”,
“Description”: “”
“Command”: “XClick”,
“Target”: “id=ctl00_Main_lstData_ctl11_FinanceDataRowInsert1_lbtnOK”,
“Value”: “”,
“Description”: “”

Ther isn’t any sucessful notification

try xclick with X,Y and image (OCR)
manual click works?

I deleted my original post because when I looked at the log I saw UI Vision had converted to the correct xpath and executed it. But I see that was on Click.

For your Xclick you should try

“Command”: “XClick”,
“Target”: “xpath=//a[@id=‘ctl00_Main_lstData_ctl11_FinanceDataRowInsert1_lbtnOK’]”,
“Value”: “”,
“Description”: “”

The xclick executed, but the number can not be saved

How to define x, y and image (OCR)?

Can you explain more clearly ----> manual click works?

This is X,Y example
XClick | 10,110

Change coordinates of the button

This is Desktop Automation Mode XCLICK example
XClick | button.png

By manual, I mean if you click the button manually, do you get desired result?

I mean that how to define the coordinates of my button , “Thêm” button

My button isn’t the image. There aren’t any image

Yes, the number will be saved ----> By manual, I mean if you click the button manually, do you get desired result?

to get X,Y coordinate
google for a tool

for image you can create one of just button and save in images folder of uivision.

Which type coordinates to use, in ( ) or out

I used two types, the number can’t be saved

here is my code

“Command”: “XClick”,
“Target”: “925,352”,
“Value”: “#left”,
“Description”: “”

Aaah, sorry, I think you’ll have to report a bug.

If you’ve tried both numbers then for sure you are clicking on it.

You could try Firefox too after you report the bug in Chrome.

you mean that is it a bug for chrome or ui vision

if command moves the curosr and does the click
still dont see result then issue must be something else

A bug for ui vision.

If that button saves numbers when you press it by hand, Xclick should have done the same.