Chromium doesn't recognize X modules installed on Ubuntu 22.04

I’m using Ubuntu 22.04 and have followed the instructions to install X modules. I’ve realized there’s a problem with libfuse, but I’ve already installed it using the following command:

sudo apt install libfuse2

Any ideas?

We will look into this, thanks for the information.

I had the same problem on a default Ubuntu 22.04 installation. I could install FileAcess Xmodule (after a few retries) and the DesktopAutomation XModule, but not the RealUserXModule. Only i use Firefox. Afaik Chromium is a snap package as well.

After debugging realized Firefox is a snap package on Ubuntu. I deleted the snap and installed the Firefox package from the Mozilla repo. Now it works.

Howto remove the Firefox snap and install of firefox .deb
[!!] Make a backup of your firefox profile. It will be deleted!!
snap remove --purge firefox #this will delete your firefox AND profile (bookmarks, extensions, settings)
apt remove --autoremove firefox #if
#add firefox repo
add-apt-repository ppa:mozillateam/ppa
#create prio for firefox packages from mozillateam
vim /etc/apt/preferences.d/99mozillateamppa
Package: firefox*
Pin: release o=LP-PPA-mozillateam
Pin-Priority: 501
Package: firefox*
Pin: release o=Ubuntu
Pin-Priority: -1
#install package, i prefer also to have the ESR
apt install -t ‘o=LP-PPA-mozillateam’ firefox firefox-esr

Couldn’t resist creating an account to prevent you from spooling a lot of time. Took me 2 days :-). Hope this resolves your issue as well.

I have the same problem on Debian 12. It does not recognize, and even after installing modules using the appimage to my desktop, I cannot edit the home folder or make any changes. There is nothing listed and /uivision (stated default folder) does not even exist as I cannot get disk usage enabled. Brand new extension install, purged completely and reinstalled. Still no luck.

Used firefox and all was located correctly, even found xmodules on desktop and installed appropriate uivision folder and contents. It may be a manifest v1 vs v2 issue. (Chrome problem - may be workaround, but not Ubuntu/Deb issue)

Thank you. I was having trouble where all of the XModules were installed properly, but the plugin would not recognize the “Real User XModule” as installed.

I don’t know what of the following fixed it:

  • Switching from snap to a package install for firefox
  • Simply reinstalling firefox after the XModules were installed
  • Switching to the ESR version of firefox