Cannot read property 'playStatus' of undefined

Hello,

I start my Autorun.html with a batch and sometimes I get the error:
Cannot read property ‘playStatus’ of undefined
My batch starts one autorun.html after another. This time it were 4 different autorun.html file and 1 of them was running successfully without any error.
All 4 Testsuite start with the same macro.
The other 3 Autorun.html had thrown the “Cannot read property ‘playStatus’ of undefined” after finishing the first macro.

Here you see the log of a failed autorun.html

Status=Error: Cannot read property ‘playStatus’ of undefined

[status] Playing test suite Create_Adapter
[status] Playing macro login
[info] Executing: | deleteAllCookies | | |
[status] Playing test suite Create_Adapter
[status] Playing macro login
[info] Executing: | deleteAllCookies | | |
[warning] Error in parsing testsuites/Create_Adapter.json:
undefined
[warning] Error in parsing testsuites/DemoLoopsInsideTestSuite.json:
No macro found with name ‘DemoDragDrop’
[warning] Error in parsing testsuites/DesktopAutomationTest.json:
No macro found with name ‘DemoXDesktopAutomation’
[warning] Error in parsing testsuites/KantuCoreTest.json:
No macro found with name ‘DemoAutofill’
[warning] Error in parsing testsuites/XModulesTest.json:
No macro found with name ‘DemoIframe_with_XClick’
[info] Executing: | echo | {!cmd_var1} | | [echo] http://localhost:60861 [info] Executing: | comment | open // http://localhost:60861/Authentication/Login?ReturnUrl=%2F | | [info] Executing: | open | {!cmd_var1} | |
[info] Executing: | assertElementPresent | xpath=/html/body/div[2]/div[2]/form/div | |
[info] Executing: | click | /html/body/div[2]/div[2]/form/div | |
[info] Executing: | type | id=Username | install |
[info] Executing: | type | id=Password | install |
[info] Executing: | click | /html/body/div[2]/div[2]/form/div | |
[info] Executing: | clickAndWait | /html/body/div[2]/div[2]/form/div/button | |
[info] Macro completed (Runtime 24.84s)

To comparison here is the log of the test which succeded

Status=OK

[warning] Error in parsing testsuites/DemoLoopsInsideTestSuite.json:
No macro found with name ‘DemoDragDrop’
[warning] Error in parsing testsuites/DesktopAutomationTest.json:
No macro found with name ‘DemoXDesktopAutomation’
[warning] Error in parsing testsuites/KantuCoreTest.json:
No macro found with name ‘DemoAutofill’
[warning] Error in parsing testsuites/XModulesTest.json:
No macro found with name ‘DemoIframe_with_XClick’
[status] Playing test suite Component_Print
[status] Playing macro login
[status] Playing test suite Component_Print
[status] Playing macro login
[info] Executing: | deleteAllCookies | | |
[info] Executing: | deleteAllCookies | | |
[info] Executing: | comment | open // http://localhost:60861/Authentication/Login?ReturnUrl=%2F | |
[info] Executing: | open | {!cmd_var1} | | [info] Executing: | open | {!cmd_var1} | |
[info] Executing: | click | /html/body/div[2]/div[2]/form/div | |
[info] Executing: | type | id=Username | install |
[info] Executing: | type | id=Password | install |
[info] Executing: | click | /html/body/div[2]/div[2]/form/div | |
[info] Executing: | clickAndWait | /html/body/div[2]/div[2]/form/div/button | |
[info] Executing: | clickAndWait | /html/body/div[2]/div[2]/form/div/button | |
[info] Macro completed (Runtime 14.61s)
[status] Playing macro Component_Print
[info] Executing: | click | xpath=//[@id=“Btn_LargeComponent”]/span | |
[warning] Error in parsing testsuites/DemoLoopsInsideTestSuite.json:
No macro found with name ‘DemoDragDrop’
[warning] Error in parsing testsuites/DesktopAutomationTest.json:
No macro found with name ‘DemoXDesktopAutomation’
[warning] Error in parsing testsuites/KantuCoreTest.json:
No macro found with name ‘DemoAutofill’
[warning] Error in parsing testsuites/XModulesTest.json:
No macro found with name ‘DemoIframe_with_XClick’
[info] Executing: | click | xpath=//
[@id=“Btn_Library_Component_ComponentId”]/span | |

Kind Regards,

Marco

Hi, please try again with the new V5.0 and the new test suites.