Button on page click not working

Hello everybody,

I use to have a great script, it ran flawlessly for 100x times, but today clicking a button on a page doesn’t work anymore. Is see the field around the button getting green because of the click, but the code behind the button is not activated. The button should trigger a “Open File” window.

I googled and found this topic https://forum.ui.vision/t/click-not-working-on-changing-buttons/1894 with exactly the same problem described, followed all the recommendations from it (except using the ocr, not shure how that works with my button). I also tried XClick, normal click, XClickRelative, but no succes…

The page in question is https://www.9kw.eu/grafik/form.html and it is all about the “Browse” button on that page.

Help is much appreciated!

Cheers, Katertje

HI

I have seen the page and the button and have not a dynamic id is a reguraly button.

Post complete macro code and comple log.

Thanks

Thanks for looking in to it. As I am not allowed to upload attachments, I will paste it here. It is not a lot anyways.

Code:

{
“Name”: “Click”,
“CreationDate”: “2020-8-8”,
“Commands”: [
{
“Command”: “open”,
“Target”: “https://www.9kw.eu/grafik/form.html”,
“Value”: “”
},
{
“Command”: “click”,
“Target”: “name=file-upload-01”,
“Value”: “”,
“Targets”: [
“name=file-upload-01”,
“xpath=/html/body/form/input[20]”,
“xpath=//input[@name=‘file-upload-01’]”,
“xpath=//input[20]”,
“css=body > form > input:nth-child(37)”
]
}
]
}

Log:
[status] Playing macro Click
[info] Executing: | open | https://www.9kw.eu/grafik/form.html | |
[info] Executing: | click | name=file-upload-01 | |
[info] Macro completed (Runtime 2.85s)

Try to add pause in every command

pause 5000

It’s probably this the problem the button seems to not change xpath

https://ui.vision/rpa/docs/selenium-ide/pause

Tried it with a pause as well. But no succes… It is stange, why is this open file dialog not being triggered? I tried two clicks, xclick, wait times in between but no luck…

Ok. I solved it by not using Firefox but Chrome instead… For some reason this open file dialog will not open in Firexfox, but it does with a simple click command in Chrome.