Button Clicks but Macro Stops

I’m clicking a button that has a dynamic ID so I need to locate it another way. I found several ways, two of which include identifying class or another locator ‘data-test’. The button successfully clicks given this target but it does not go to the next command line in the macro. It times out.

Both of these work to click it, but then the macro stops:

It clicks the ‘…’ button and opens this menu but won’t execute the next line of code to click ‘exportResults’ button

I even tried XClick and that doesn’t work - it finds the button but then nothing happens. And then this red box with a confidence score appears on the screen and it stays that way.

<span class="input selectSettings">
		<a class="cui4-button" id="pipeButton-mzZJUHsZ" data-test="selectSettings-button" href="#">
			<svg class="cui4-icon cui4-icon--s"><use xlink:href="#icon-sm-ellipsis" href="#icon-sm-ellipsis"></use></svg>
				<use xlink:href="#icon-sm-ellipsis" href="#icon-sm-ellipsis"></use>

Now the XClickRelative line passes as green however the actual box is not clicked so the next line cannot proceed

Figured it out: I put in pause | 3000 right before the click and now it works like a charm. It’s amazing what 3 hours of persistance will get you