Bug Report: In Firefox, File System on Hard Drive: Does not create macros; crashes Firefox

The problems reported here only apply to Firefox. The problems were not reproducible in Chrome.

The problems are:

  1. UI Vision RPA Kantu with Storage Mode set to File System (on hard drive), RPA does not allow creating new macros.

  2. UI Vision RPA Kantu crashes Firefox.

The steps to the problem are shown in this video:

Steps to Problems

I am very appreciative that UI Vision actively seeks user bug reports such as this one. I hope I am providing enough information that a UI Vision developer can easily replicate the problems. If not, please contact me for more information.

Hi

In your video i do not see ui vision in action and i do not see any firefox crash.

Please post the macro code to know your problem.

There is no macro code because UI Vision would not create a new macro. That is the problem. I apologize because now I see the video is too low of a resolution to see a lot of things. Understand that I am very much a beginner at making these videos.

I will point out where to look in the video by time in minutes and seconds. 0:00 is the beginning and 3:17 is the end of the video.

At 0:32 you see me changing from Local Storage to File System.
At 0:48 through 0:59 you see me attempt to create a macro. You see nothing happen. That is the problem.

Then I go on to demonstrate that Firefox crashed. First, I switch back from File System to Local Storage at 1:30.

The first symptom of Firefox beginning to crash is that I can no longer switch from Local Storage to File System, demonstrated at 1:41.

At 1:50, I close UI Vision and Firefox. At 2:01, I try to start Firefox again. At 2:08, you see what I’m calling the Firefox crash message. It says, “Firefox is already running, but is not responding. The old Firefox process must be closed to open a new window.” Options are “Close Firefox” and “Cancel”. I choose the “Close Firefox” option.

At around 2:25, I try to start Firefox again. At 2:30, I select to not make Firefox my default browser. Firefox’s response is to open two windows. I presume one was for the UI Vision controlling window and the other was for the controlled window that were open when Firefox crashed.

At 2:50, I demonstrate that after closing and restarting Firefox, I am again able to switch to File System.

At 2:54, I select Local Storage. Then I demonstrate that UI Vision does make a new macro in Local Storage mode without crashing Firefox.

You see at 3:13 that the new, empty macro was created.

I don’t know whether the video together with this post is enough. If you need to see more, then maybe I can see whether I can find how to increase the resolution so you can see more in the video.

Maybe I am not using the term “crash” correctly since I have not shown anything freezing. But you can see that there is some kind of a problem when I try to create a UI Vision macro when UI Vision is in File System mode.

And I can reproduce this on my computer consistently. It is not random.

I was able to see where to increase the resolution. You may want to look at this video in which I demonstrate the same things:

https://drive.google.com/file/d/1x0wmkqd5VVRLBCS1MXr00CKUvCppJs3W/view?usp=sharing

I just noticed that there is a new release 5.3.10 for Firefox. UI Vision is showing this version. So, I think the problem is still in this latest release.

Hello I already reported this problem is xmodules 201908, read in this post, does not make you create macros because xmodules 201908 often is not detected even to me happens, and continuously is detected and not detected sending firefox in error, read here and if you can write and reproduce errors in their test machine for correction.

Write here and try to recreate the bug with admin machine please.

Thanks for report this bug.

Sounds like I am invited to reproduce the bug on a UI Vision test machine. I am happy to do so, but how? Is there a link I click to get to the test machine?

I will explain why I am trying to use Firefox and not Chrome. I would like to use Chrome. On the Schwab.com website, I can use Chrome for most functions, but not for screeners. Screeners is a way to select stocks to buy or sell. The screeners function does not show up in Chrome. I can use Firefox for all functions in Schwab.com. That is why I want to use Firefox. But now UI Vision is not working in Firefox. And I am trying to use UI Vision to automate my use of Schwab.com.

Now I discovered that Opera browser does see the screeners in Schwab.com. And by installing an Opera extension called “Install Chrome Extensions”, I can install UI Vision in Chrome. The question is whether UI Vision will work. I am looking into that now. So far, I see that I can make new macros in both Local Storage and in File System Storage. I’ll try to remember to post here whether UI Vision appears to work in Opera.

I have the same your problems but i solved using this configuration Firefox portable ESR 60 (i use FirefoxPortableESR_60.9.0_Italian.paf.exe) with ui vision 5.1.9 with xmodules 201905 and works well.

Step

  1. unistall xmodules 201908 (latest) from your pc

  2. reboot pc

  3. install old xmodules 201905 (it have not only xrun command and few new function)
    Link: http://download.ui.vision/x/ui.vision-xmodules-setup-v201905.exe

  4. Istall in a prefered folder firefox portable ESR 60 (I used all firefox version only with this version there are any bugs)
    Link: https://sourceforge.net/projects/portableapps/files/Mozilla%20Firefox%2C%20Portable%20Ed./

Open firefox and install ui vision 5.1.9
https://addons.mozilla.org/it/firefox/addon/rpa/versions/

Set xmodules path in ui vision addons and now you are ready to automate.

I’m finishing my post about using Opera.

So far, looks like Opera will work. You have to make sure that UI Vision has the required permissions. I did not determine which permissions are essential. So, one might be extra and unnecessary.

Procedure:
After installing “Install Chrome Extensions” and “UI Vision”…

  1. Goto Opera Extentions by
    a. Click on the O in the upper left corner to get drop down menu.
    b. Go to Extensions >> Extensions

  2. Find UI Vision extension and enable everything, which amounts to:
    a. Allow Access to file URLs
    b. Allow Access to search page results

With these enabled, UI Vision seems to work, so far. I can create, record, and run macros.

Now, I go to try what newuserkantu’s posted.

Thank you, newuserkantu.

Looks like your procedure works for me. I can now make new macros in Firefox in File System mode.

When I tried Opera browser, a macro did not work until I changed a line from
selectFrame | index=1
to
selectFrame | index=2

Then, when I tried your procedure, the macro again did not work until I changed it back. I would think it would be the same HTML that each browser gets from the website. Or would different browsers interpret the HTML differently?

In anycase, looks like your procedure will allow me to run my macros without change. This can keep me functioning until the UI Vision is fixed. Then I can use later Xmodules.

Thank you.

It is possible that the site uses a dynamic frame that changes or it is possible that opera uses a different method of counting frames.

Personally I noticed that the frames are the most difficult part to automate, usually to switch in the frame I use 2 codes

selectFrame | relative=top
selectFrame | index=1

First I return in top frame (= outside all frames) after i switch in frame index=1 or index=2, change frame directly (selectFrame | index=1) for my experience can give some error.

In the cases is very hard to detect correct frame you can bypass this using emulation of KEY_TAB to switch in element in the page (with XType command anche XClic) or image recognition, these modality no need frame.

https://ui.vision/rpa/docs/xtype

https://ui.vision/rpa/x/desktop-automation

I was going with Opera. But then, I was not able to get executeScript in Opera. And then, Opera stopped working in Schwab.com website.

Firefox is working for Schwab.com. So, now it looks like your advice, newuserkantu, the best advice for me: Use the old UI Vision 5.1.9 xmodules 201905.

Thank you again for the links and advice.

I am sure that UI Vision Xmodules problems are temporary because I see that UI Vision cares a lot about their product. Software problems can take a long time to fix. Fortunately, I have newuserkantu’s workaround in the meantime.

1 Like

Please retest with V5.3.17 - most likely this issue is fixed.

I tested and am unable to reproduce the problem. Indeed is fixed in V5.3.17.
Great job.