[BUG] Click event issue with Chrome 97


I’m using Chrome 97.0.4 with Windows 10 and UI Vision 6.3.3.

With the Chrome 97 update I can no longer click or XClick (including relative XClick) a button with any locator approach (attributes/xpath/relative xpath). The button should launch windows explorer for a file upload in a web app, but in Chrome 97 the element (area around the button) is clicked instead for all approaches.

I can’t revert to a legacy version of Chrome because my browser is managed by my company, but I have confirmed the issue is only present since the Chrome update using the previous version of Chrome on a personal machine.

This is the page HTML:
< p class=“pagecontents”>Attach a file to this e-mail template:
< br>
< input class=“pagecontents” type=“FILE” name=“FILE_TO_UPLOAD” value=“Browse…” size=“20”>

Prior to the Chrome update this worked consistently:
“Command”: “click”,
“Target”: “name=FILE_TO_UPLOAD”,
“Value”: “”,
“Description”: “”

I haven’t been able to get OCR to work for this. Users of the macro have a multi-monitor set up, so an OCR solution isn’t ideal anyway. Executing a javascript snippet hasn’t worked either.

Clicking via the name element for the button works as expected in Firefox (96.0.1). However I don’t use Firefox because I can’t send ${KEY_ENTER} for other actions via sendkeys/XType (I haven’t tried a VB script workaround with Firefox yet).

Thanks for your help.

Is this “just” one specific button on a certain website?

Hi Ulrich, yes this is the only button I’ve had a problem with so far. The button is in a separate window which I open as a tab. The sites (ScholarOne) are third party and the area in question is only accessible to users with elevated access.

As a test, can you try in Firefox?

The click event works as expected in Firefox but sendkeys/XType for the enter key doesn’t (see first post), so I can’t automate Windows file explorer.