Automating clicking a check box

I’m using Command ‘click’ on a check box and the “tick” is not stating in the box. When watching the Macro the tick appears and disappears again . This is failing my test as the Macro cannot continue.

Has anyone experienced this and can help?


I have encountered the same error - the solution is simple, you need to add a value of 0 to the click command.

Hi Takwej,
Thanks for the reply.
Unfortunately that’s not working for me. Tried other number values too 0,1…etc. Also the DOM inspector states “value=Y”. In addition other boolean such as a “T”
Thats not working either!


After last update some checkboxes that Kantu first compiled now with the latest version 4.1.12 no longer compiles them.

Is very strange this situation

This is the html code of checkbox, from the version 4.1.12 Kantu do not recognize, with older version working

<div id="privacy">
<p class="privacy-block form-check">
<input type="checkbox" name="privacy" id="privacy" class="form-check-input" /> 
<label class="form-check-label" for="privacy">TEXT1 <a href="" target="_blank" title="title">Text2</a></label>

Thanks for suggestion

Solved this a solution

      "Command": "click",
      "Target": "name=privacy",
      "Value": ""

With recording mode of Kantu saved xpatch or css element and do not recognize the checkbox, i tried this code manually (i found it in the forum) and works, click the checkbox

Solved, thanks