XClick fails after running new macro in same Chrome window

Hey all. I have a bunch of macros who essentially do the following:

  1. Open a website
  2. Login
  3. Click around using XClick
  4. XClick hits a link that opens in a new tab
  5. Closes that second tab
  6. Logout

The macros work great on their own but if I run them in sequential order or as a testsuite, XClick will fail (at random) for no apparent reason. It isn’t specific to a single XClick command, any one of them in my macros will fail at random, sometimes I make it to step 20, other times to step 50, it’s completely random.

If I close Chrome and reopen Chrome after every macro, XClick works fine. I’m trying to set up testsuites to run overnight, and this issue prevents me from doing that.

I’ve tried deleteAllCookies, Incognito browsers, nothing seems to prevent this issue. I am only able to successfully run my macros if I close Chrome and Open it back up again.

I can’t find any forums relating to this issue, nor can I find a way to close and open a new Chrome instance in a macro.

This part can be done with the RPA command line.

Opening and closing Chrome via command line gives me "Error #101: UI. Vision RPA is not connected to a browser tab .”

Running macro’s 1 by 1 works fine, but running a test suite seems to cause issues with the failures.