[UI.Vision RPA] Error #150: No tab for dashboard yet

I am using the api to run a long script.
When starting I get the Error

[UI.Vision RPA] Error #150: No tab for dashboard yet

8 out of 10 times.
To start I open the chrome and wait for 40 seconds, after that I run an empty macro to open the extension:

  "Name": "OpenRPA",
  "CreationDate": "2021-10-15",
  "Commands": []

I use UiVision 6.2.8 in hdd mode.
To show the problem I created a little gif:

Could you point me into the right direction to solve this problem?



This bug is caused when you run macro via bookmarkes or command line

There is not solution to solve, it caused when ui vision try to run macro before browser loaded.

A good solution is have more ram or run macro after browser is already opened

Duplicate post. See
Occasionally getting "No tab with id:" error - #7 by trexem
Kantu Chrome 'No tab for dahsboard yet' Error - #7 by trexem

Thank you for your comments.
This makes working automated scripts via api rather unstable…

I open the browser 40 seconds before I try to run a command and have 6GB of Ram…
Will try to open the browser about 60 seconds before running the first command.

Sorry I read it but did not connect the dots…

@admin would it be possible to merge the two theads?

Thanks again for your help.

[UI.Vision RPA] Error #150: No tab for dashboard yet

Kindly help me with this, I am having same error


I am getting “Error #180: No connection to browser tab” regularly, when using the api.
Interestingly the log file is not saved, am I doing something wrong?

Thanks your help.

I am in the same case. “Error #180: No connection to browser tab” Any solution?

Version 8.0.1

there is a specific threat for this topic.
I posted a workaround that works for me there:
Error 180

Note: The #180 issue is fixed with V8.1.1.