Ui.Vision RPA Chrome extension: Migration from Manifest V2 to Manifest V3

I’ve just received a run test case error a few moment ago.
V7.0.7 is making us change so many details, and still got the error of old version.
Could I just get a V6.3.3 as soon as possible?

Hi, why do you think that 6.2.8 is slow? Actually, V6.3.3/V7.0x is a bit slower because the new manifest V3 makes us to do things a bit more complicated.

@alex_loh the !clipboard variable issue is solved with V7.0.8.

1 Like

because I have tested it on my device so many times.
V6.2.8 is more likely to have erors than V6.3.3.
And it might be slower or faster depend on the internet speed but V6.3.3 is definitely better.

Could you just make it instead of recommend me using V6.2.8?

Gotcha, thanks @admin for helping out!

Also just want to report that version 7.07 still crashes on chrome. I was running the scripts midway and the page itself crashed :frowning:

The only difference this time is that the app extension stays, last time when it crashed the app will disappear from the extension.

Would the older versions help with the crash? Or version 7.0.8 help mitigate it?

Hi! :wave:
The Memory leak issue seems to be back in 7.0.7. :face_with_diagonal_mouth:

1 Like

Johan, is the out of memory bug causing the app to crash for you as well?

2 No tab with id errors in a row.


I’m hopeless with this version. Please make V6.3.3 to the archive, and I can continue with my works, while you can fix bugs in that time.

@admin @ulrich

@johan Do you have a test case for the memory leak issue? I was running the “demoFrames” macro for more than 1000 loops without an issue (2-3 hours).

2 No tab with id errors in a row.

How do you start the macro? (I mean, what command line do you use in the task scheduler. And do you get the same error if you start one of our macros e. g. DemoFrames?)

@admin I run a ps1 file by powershell, and the script inside that file would run macro.
This is the script from ps1 file I run by powershell:

Start-Sleep -Seconds 5

Stop-Process -processname chrome

Start-Sleep -Seconds 10

Start-Process -FilePath "C:\Program Files\Google\Chrome\Application\chrome.exe" '--profile-directory="Profile 12" "https://www.google.com/"'

Start-Sleep -Seconds 20

Start-Process -FilePath "C:\Program Files\Google\Chrome\Application\chrome.exe" -ArgumentList '"file:///G:/My Drive/uivision/ui.vision.html?macro=F1-payoutAuto.json&closeRPA=1&closeBrowser=1&direct=1" --profile-directory="Profile 12"' 

I never heard of DemoFrames. What is that and how could I test it? Does it help me to make the autorun macro not having the no tab with id error? Could you guide me?

I just know if I open UI Vision by clicking on extension icon, and hit Play Macro, it would run perfectly fine.

Hi @kolor_blind Can you please try adding PAUSE | 3000 at the top of your macro? Does this help? (= avoid the “no tab ID” errors)?

Could you please mark this problem as one of your hardest problem to solved? Because adding pause doesn’t help. I tried adding BringBrowserToFront, tried PAUSE | 10000, tried open Chrome and wait for 30 seconds or even 1 minute and the start the UI Vision.

All of the methods above are not working. The problem is not in the script. It’s in the way UI Vision interact with Chrome. Not only no tab with id, but there are several other warnings that I don’t know how to get rid of.

This is very high on our todo list. We will address it as soon as the Manifest V3 transition is done.

Note: You are right that the problem is related to interaction with Chrome. Because if you use “only” XClick, XType, ExecuteScript_Sandbox and other non-web commands, the issue does not happen.

Yes, but all I want to do is just web related commands, because I want them to play in the background in my VPS without my attention. That way the macro could run while I don’t even open VPS, so I could run them in my sleep.

Please try to figure this out. And if you could, make a more specific instruction on how to use executeScript in this new Manifest V3, because my macros are all messed up after V3. I’m having a problem with 2 similar structure macros but give different results that I’ve already posted it on forum.

no reply to this? my macro is crashed and could you help me? @admin

@kolor_blind the “tab ID” issue is on our todo list. We do not have a fix for it yet. Or are you referring to another issue?

I was posting a new post about that problem but @ulrich got me through.

I’ve just read the OP so I’m linking my issue here, as requested:

There’s also a similar issue here:

Finally, you say we can run v6.2.8 “in parallel”, does that mean if I install it another button appears next to the current version’s button? I don’t have to uninstall anything?

Thanks.

May 9th, V7.0.11: The list of known issues is getting smaller with each update. As of V7.0.11 the current list of open issues is:

If you notice anything else, please report it in the forum.

1 Like