New UI Vision version is not running perfectly (but works in new profile)

I get “This video cannot be rendered because your browser does not support the codec.”

Thus I can not play the video :frowning:

Can you please reupload the video and/or provide a test macro? What does not work?

You can see it right here.

I even have a !timout_wait command like this:

And when it comes to the command that needs checking,such as verifyText, verifyElementPresent, and some click command under store | true | !errorIgnore; it doesn’t show the waiting time as usual.

Something must be happened with the new version.

New update @admin

  • This script is to adding new information into Trello Cards. Usually I and my friends use the same Trello board, and each one of us has an Trello account for ourself.
  • Yesterday, none of us could run that script and we had the same problem as I stated upthere.
  • But today, when I sign in another Chrome Profile, then sign in a new Trello account that still can access that Trello board, and run the script, it run just fine.

So I don’t know what is the problem here. But this does affect to my workflow, since I can’t just abandon my old Chrome Profile, and my old Trello account like that.

Please help me, thank you a lot!

Thanks for the info. If all works fine with the new profile, then maybe there was an issue with the upgrade process.

As a test (in the old profile), can you try this:

  • Uninstall UIvision
  • Close all open Chrome instances (not just this profile)
  • Reinstall UIvision

Does this solve it?

@admin I’ve just tested it and it’s still the same.

This seems tricky, because we can not recreate the problem. As short term solution, I recommend to go back to V6.2.8. We just published a link for it in the RPA software archive.

I tried to install this old version yesterday, but it keep telling me that I need to install Xmodule, when I already have that.
Could you tell me how to fix that?

Try again now, we made a custom V6.2.8 installer :slight_smile:

it worked, thanks a lot @admin

In my case on verifyElementPresent not only does it not find it as usual but the macro hangs and loops on Tag waiting. After the 10 second count the timer starts over, counts to 10, starts over… forever.
In the log it doesn’t show any error nor does it timeout as expected, just stays on the verifyElementPresent command:

[info] Executing: | verifyElementPresent | id=um-submit-btn | |

I already removed and reinstalled 6.3.1, tried starting from CLI and from the extension manually, added a pause after selectWindow | tab=open as mentioned above but no change.

you should try the link that admin commented above, try the 6.2.8 version. It worked for me.
Just uninstall the old one, or not. Then click on the 6.2.8 link.

Thank you… how are you selecting which version to use when starting macros via CLI?

could you please tell me what is CLI? I only run my macro through Chrome extension.

If you don’t remove the old version, there would be 2 small UI Vision icon in the extension zone. Just remember which one is the new one and click on it.

I think you should remove the old one, that would help you out.

Command-line interface. You can start macros and add them to other automation scripts: UI Automation Open-Source Selenium IDE plus additional features, iMacros alternative

I was going to run both versions to help debug on the new version but keep my macros running on the working version.

Thanks for your help debugging :slight_smile: To switch between RPA versions when starting UI.Vision from the command line (CLI), disable (in the extension section of Chrome) the version you are not using.

@User9898 Does this happen with any macro, even a small test macro? If so, can you post a test case?

After more testing, it appears that it fails if the element is not found. Here is a video:

  "Name": "test2",
  "CreationDate": "2021-12-20",
  "Commands": [
      "Command": "bringBrowserToForeground",
      "Target": "",
      "Value": "",
      "Description": ""
      "Command": "pause",
      "Target": "5000",
      "Value": "",
      "Description": ""
      "Command": "selectWindow",
      "Target": "tab=open",
      "Value": "",
      "Description": ""
      "Command": "verifyElementPresent",
      "Target": "id=um-submit-btn",
      "Value": "",
      "Description": ""

@User9898 Thanks for the test case! → I recreated the issue and opened a ticket for it,

Issue fixed with V6.3.2