Macro freezes on visualVerify command

First of all I noticed this issue in Chrome but now it also appears in Firefox:

I created a macro including some “visualVerify” commands. At the beginning the test worked as expected. Every command run and no failure. But now when I run my test the tool stops at the visualVerify command. The log says

[info] Executing: | visualVerify | 1440_kopfbereich_hp_oben_dpi_96.png | 1000 |

with no change for at least 5 minutes now. In the above right corner I can click on “stop” for the macro and the tool reacts on this. But whenever the test reaches step 4 it stays there and nothing happens.

As described I first realized this with Chrome. Then I exported the macro and imported to my Firefox and everything worked fine. Now the same happens here. I did some changes on the macro before it stopped working.

Does this happen “only” to one specific command, or all visual commands on this machine?

Does recreating the image solve it?

It happens to all visualVerfiy commands in the macro as well as to a visualAssert command.

It seems to me that some processing is running in the background: the computer get louder and stays loud until I close Firefox. Additionally when I re-open Firefox the macro works again for a few times but stops from working - and I do not get it when. One time I right-clicked on a command and chose “Play from here” and after that it stopped from working, sometimes I was able to use this and everything worked fine. I hear my computer processing something until I close Firefox - and when I open Firefox I will work again for a few times.

Strange. Another question: Does the same happen in Chrome?

yes, the same happens in Chrome

Strange issue. Some more questions:

  • What OS? Win, Mac or Linux?

  • Can you test on another machine?

  • If you run DemoXDesktopAutomation, does this macro work ok?