[#Issue 656. Work in Progress] Firefox Xmodules not working after update

Admin Xmodules 052019 with Kantu 5.1.9 on firefox ESR 60 working.

I add an image.

When I tried Xmodules 082019-082019a with Kantu 5.2.3 on firefox 69 and firefox ESR 60 in the same machine sometimes the xmodules will not detect (sometimes will be detect and sometimes not), I closed and reopened more times firefox to check this).

I suspect when xmodules 082019 will not detect from Firefox Kantu create a loop and cpu go on 100%.

To verify i suggest you with Kantu for firefox 5.2.3 + xmodules 082019a to create a simple batch file and try to run more times firefox wth a macro that use xmodules and check if sometimes xmodules will not detect and macro failed to start (for my opinion is random the detection).

firefox ESR 60 + kantu 5.1.9 + xmodules 052019 working on windows 7 32 bit italian (no freeze, no cpu 100%)

1 Like

Win8.1x64
Chrome - OK
Firefox - Not installed

2 Likes

Hi have the same problem, sometimes firefox detect the xmodules 20198a sometimes no, try with a batch file to run multiple times firefox with hard drive mode and you see this problem.

I reported in the forum but not solved.

Welcome back to the forum it was a long time since I saw you writing.

Hi

Check xmodules 20198a and firefox addons 5.2.3 because in my opinion latest xmodules and latest firefox addons do not work and there are others users that report this, please check admin

@admin

No reply, no support, no solution why ?

How can you work with a software with bugs ?

How do you think someone will buy your software by reading that have bugs ?

Do something and try to solve problems.

Do not read that already several users have reported the problem and you of the assistance you have not done anything to solve the problem, why ?

Please read and investigate the problem to find a solution otherwise users will go and buy other software to automate that do not have the serious flaws that Kantu has.

@commensal @fellcroft
For users who have this problem please write it here otherwise kantu assistance will do nothing to fix it we keep this post active otherwise it will never be fixed.

The problem is that we can not recreate the issue. That is the key challenge here :frowning:

@newuserkantu (or others): I would be happy to give you remote access to our test systems via Teamviewer or AnyDesk if you think you can recreate it. Maybe we do things (by chance) in a certain way that avoids the issue…?

Or any idea what is different on your system(s)…

@newuserkantu Did you test with the latest beta version 5.2.15? This version contains a few Firefox related fixes. Another fix for Firefox 70 is on its way with the next update. It would be great to know if using this version changes anything for you.

Beta: https://chrome.google.com/webstore/detail/uivision-kantu-for-chrome/dpdlhdbnlaefobeejcgfidghdllhemkl

Thanks for reply

I tested Kantu for firefox not Chrome

I tested this firefox addons 5.2.3

With xmodules 201908a

https://ui.vision/rpa/x/download

On Windows 7 32 bit on virtualbox (my windows is base version with service pack 1).

It’s not just me who has this problem, if you read in the forun there are various reports so it’s a general problem of the new xmodules or firefox addons 5.2.3

Ok - the new Firefox version of 5.2.15 will be available in roughly 10 days.

1 Like

Thanks i wait to try new addons

15 days past - no update and add-on is still not usable. Funny cause my firefox is a fresh install. Now even if i want to try if addon is ok I have to restart browser since it’s 60% CPU use after launching kantu. Sad case.

Hi if you have possibility to collaborate with the admin with anydesk or teamviewer to solve this problem, thanks

Hello @admin
i’m using french Win 10
I have just installed the latest version on Chrome and Firefox and the two of them can’t detect the Xmodules.

Hello @admin
After a lot of test i think i have find the problem:

I had kantu 5.1.9 and xmodules 201905 installed and working fine in 2 Windows 7 x64 machines with firefox upgraded.

As lot of people here in the forum, when i tried to update the kantu version or xmodules version i received the error no modules found and 100% cpu and when i close firefox, 2 instances of firefox keeps running in the background and i must close it by hand.

No matter all i try, install only kantu update install only xmodules, unistall first, reboot, i tried a lot of combination with same result, the very moment i updated one of them it all stopped working.

So i decided to try a fresh install in a new test machine, maybe it was windows 7 about to reach end of support, so i installed a fresh windows 10 x64, firefox 71, rpa 5.3.7 xmodules 201908a, and everything went fine, no matter how many times i restarted the computer, every time it detected the xmodules and the cpu use was below 4%, so i thought, problem solved is something inside windows 7, so i proceed to upgrade the windows 7 machines to windows 10.

No luck.
The old versions keep working like charm but when i tried to upgrade everything was broken again, what the hell was happening, maybe any firefon add-on causing trouble? i disabled all but kantu-rpa, same result, cpu 100% and xmodules not working, uninstall firefox, kantu xmodules, fresh install…

Then miracle: xmodules detected, rebooted computer, xmodules keeps being detected, cant believe, reboot once more, xmodules still working, then i had a revelation, i ran to the windows 10 machine test and checked 2 things:

I have not selected my hard drive as storage mode, the test machine still had selected in browser mode.
I noticed instead of using the old kantu folder in desktop i had created a new folder called uivision in desktop and selected as xmodules home folder, so i copied my macros to that folder and:

BANG! everything broken again, no detection of modules, computer unresponsive, 100% cpu.

I thing the problem is when we use the local storage, what is the purpose of installing xmodules in the first place or the new folder name or both of them or maybe none.

I hope this helps you and point in the right direction to solve this problem and if it does, i could accept a xmodules personal license as christmas gift :wink:

2 Likes

@kantuser

Same situation for me

Update: Hooray! User @kantuser logged into our test system and was able to recreate the bug there! So the “xmodules not detected” bug has been located - it happens when there are many (500+ ) macros or CSV files in the folders.

With the latest XModule version we support files > 1 MB size, and this puts more strain on the native messaging communication between browser and app. Now that we know this, we will be working on the fix (Bug tracker ticket #656). This will take some time (1-2 weeks?), as we need to change the way we load files in hard drive mode.

Workaround until then: Remove all CSV files, images and macros that you do not need from the directory, so that only a few are left inside the folder. Then all should work fine right now.

I will update this thread once a real bugfix is available.

(This is not the solution yet, but I mark it as solution for now, so everyone sees this comment :slight_smile:

Hi

I have not 500+ macro, i have this bug with the demo macro installed.

I can not use Ui vision because when I installed it freeze firefox, i do not create any macro.

With windows 7 SP1 this bug appears when you install ui vision and xmodules 201908.

I think the subfolder are very slow to load in firefox.

1 Like

@newuserkantu Can you please contact me so I can give you access to our test system? If you can recreate the bug there, then we can fix it in the next 1-2 weeks, too.

I writed an email now from g******i@email.it

***** to avoid spammer in the forum

Nor do I.

oftopic:
@admin Will ya remove please stupid 20 mandatory characters post rule?