I can't find the source of this error

I’m new to Kantu. I have a simple script that runs. If I make a change to the script, any change, I get this error:


Playing macro Test

[error] ask is not a function

Even reducing the script all the way down to no commands does not clear the error.

Has anyone seen this before?


We have seen and heard about this error before, but we have a hard time recreating it on our test systems. Therefore some questions first:

  1. Are you using Kantu for Chrome or Kantu for Firefox?
  2. If the error happens, do the demo macros like DemoAutoFill also fail?
  3. Are you using Windows, Mac or Linux?
  4. What version does your Chrome and/or Firefox have?

PS: If you are using Kantu for Chrome, it will be nice if you can try on Kantu for Firefox, or vice versa. And then see if you still get the error.

I tried it on both chrome and Firefox. The demos fail with the same error. I’m using a Mac 10.13

I’d be happy to help you debug this if I can.

Do you get this error before or after the change? Do unchanged macros work?

I can’t say exactly what causes the error, or what clears it. Once I have the error, no undo’s clear it. It seem like an internal state gets set, causing the error. Reloading the page, closing the Kantu window do not consistently clear the error. Quitting and reopening the browser does. Creating a new macro has cleared the error, but not always.

Creating a new macro, trying to run it, even though it’s empty, then going back to the failing macro seems to clear the error.

I got the same error and creating a new macro does NOT WORK! This problem is stopping me from working!

This problem is happening after the end of the first loop, when it trys to run the next loop, on firefox and chrome. Demo macros do not fail, windows server 2012 R2 datacenter. Latest Firefox and Chrome.

“[error][ignored] ask is not a function”

here is my script: https://pastebin.com/raw/YamdSdZF

It looks like this error is happening when I use

  "Command": "store",
  "Target": "true",
  "Value": "!errorIgnore"

ok let me correct: it should 99,9% have something to do with ipcPromise, since Im getting a "

[error] IPC Promise has been Destroyed."

here you can recreate the ipc promise error: [error] IPC Promise has been Destroyed

looks like nobody cares…, oh well

We do care… it is just that this issue was complex to recreate, debug and fix.

But now its done: IPC issues are fixed with Kantu V3.1.6 :grinning:

1 Like

I have recently tried to install itunes on windows 7 but I encountered with an error which is really a problem. The system is literally crashing and I cannot find the source of the problem. Please help me to fix the problem.