Chrome V86: RPA running slowly ignoring !ReplaySpeed [Workaround available]

Today I was running codes that have been running daily for months and I noticed the speed of the running code was slower than usual. I’ve tried everything by now, the code already had the store | Fast | !ReplaySpeed, I tried adding a bunch more in random places of the code, I already rebooted the PC, reinstalled Kantu and it just keeps running slower than usual. Codes that used to run in like 5 minutes or less now take half an hour or more.
Looking just at a pause | 30000 | I looked that the seconds run weirdly, some run smoothly (1 real second per number in kantu) but in others it stucks like 3 real seconds.
I added some echo | ${!ReplaySpeed} | and it throws FAST, but it’s not actually running Fast :slightly_frowning_face:

Please help :frowning:

you do not minimize ui vision windows, can this the cause

mantein ui vision and browser on screen on focus

I remember it used to happen if the Kantu window was minimized and now I don’t minimize it, just leave it in the background, but it’s running so slooow

Try if your macro have error or elements not found

The macro is not failing, and yeah, I think it has to be that the ui vision’s window is in the background because i manually click to bring it to foreground and it runs smoothly
But I need it in the background to use searchImage. And as I said, it’s not minimized. Heres what I do:

  1. xtype windows+d to minimize all apps
  2. open ui vision’s windows again by clicking in the taskbar
  3. open chrome
  4. bring chrome to foreground
  5. run everything else

That’s what all my macros do at the beggining, and it used to function just fine, but today it started running slow as if the ui vision’s window was minimized

I suggest to reinstall browser and ui vision

Most of the problems are due to the fact that in the browser they interact multiple programs together, so many times I had to reist ui vision to fix seemingly inexplicable bugs

For this reason i do not use Chrome because need installation (portable version too) i prefer firefox portable in a pendrive, when there are a problem i delete folder and recreate a new firefox folder fresh and working.

I already reinstalled ui vision, will try to reinstall chrome. I’ll post my update later

I can’t help you I’m sorry, we wait @admin to answer you but it seems difficult to understand the problem without elements

1 Like

Yes, if the window is minimized, Chrome slows down the Javascript execution dramatically. But just leaving it in the background should be fine! => Can you please post a screen video of the slow execution?

In our tests all works fine when the RPA software is in the background (= no focus is ok, hidden by another app is ok, even off screen is ok) but it must not be minimized.

This is a bug that’s now popping up in Chrome 86. This doesn’t happen in version 85. I’ve confirmed this on three different machines. It’s not about minimizing. I never minimize the window.

With the window in the background, the extension is running very slowly. This breaks pausing and looping in my scripts unless the window is in the foreground.

1 Like

Make sure the tab isn’t in the background also. Chrome now throttles JS timers for background tabs. Try turning that off in chrome and see if that helps: In chrome://flags and looking for Throttle Javascript timers in background or #intensive-wake-up-throttling and disable it

1 Like

This seems to have fixed my issue. I always keep the tab in the foreground and the RPA window in the background. After changing this flag RPA operates properly.

Looks like I spoke too soon. The issue is still happening.

1 Like

Yup, still not working
Reinstalled Chrome and UI.Vision and still going so slow. Tried disabling the Throttling flag and still going so slow.
I guess I’ll try to go back to version 85 of chrome or something

Try firefox is better like browser.

I use firefox portable with some addons is fast and working well you can run multiple instance in same time to have multi threads.

No problem with firefox and it’s the only browser to run multiple work in same time.

it’s not that easy to change the browser. But i guess I’ll do it.
have to change tons of code that worked with chrome path and chromelike windows :c
thak you @newuserkantu, i guess it is for better to change now than keep developing stuff in chrome

I prefer firefox for 3 things

  1. firefox require less memory of Chrome

  2. With firefox I can open multiple browser in same time, need only to create new folder with firefox portable (need not to create multiple profile like Chrome hard and slow).
    With firefox you can run unlimited browser in few minutes if you need.

  3. If i have a problem (corrupted browser or corrupted addon) I simple delete folder with firefox portable and recreate new folder and run again browser and ui vision in 30 seconds.

I use portable version only.

I have the same problem with my scripts.

This happens only on browser chrome 86.0.4240.75 (64).

This must be solved guys. What is the issue?
We cannot simply just change browsers.

1 Like

Waiting a solution from @admin

Macro codes are compatible between firefox and chrome so it’s very easy to switch between browsers

The same macro code working in Chrome and firefox e probably in opera (with addon) and edge.

Only some Xclick and Xtype can different from various browser

Here an example that we are not minimizing UI.Vision’s window, it is just not in the front and runs slowly.

Here the code, just typing a loop variable in google’s search page

{
  "Name": "test",
  "CreationDate": "2020-10-12",
  "Commands": [
    {
      "Command": "echo",
      "Target": "${!ReplaySpeed}",
      "Value": ""
    },
    {
      "Command": "store",
      "Target": "FAST",
      "Value": "!replayspeed"
    },
    {
      "Command": "store",
      "Target": "0",
      "Value": "loop"
    },
    {
      "Command": "while_v2",
      "Target": "${loop} < 60",
      "Value": ""
    },
    {
      "Command": "echo",
      "Target": "${!ReplaySpeed}",
      "Value": ""
    },
    {
      "Command": "type",
      "Target": "name=q",
      "Value": "${loop}"
    },
    {
      "Command": "executeScript_Sandbox",
      "Target": "return Number(${loop}) +1;",
      "Value": "loop"
    },
    {
      "Command": "end",
      "Target": "",
      "Value": ""
    }
  ]
}
2 Likes